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What is CatBase?
It’s a data publishing application for creating catalogues, directories, price lists, or any sort of 

publication that’s based on a database or spreadsheet. CatBase automates the tedious, time-con-
suming, and error-prone process of selecting, sorting, and formatting the data when it is published.

Why do I need to use Word as well?
You use CatBase to manage your data and to prepare it for publishing. When you publish your 

data from CatBase, it creates a text file that contains your data, sorted and organised the way you 
want it, with style tags embedded. When this tagged file is opened up with Word, Word handles 
the actual formatting of the text (and pictures). As you’ll see, this gives you an incredible amount of 
flexibility and control over your publication.

How does Word know what to do with the data?
You set up Publishing Projects in CatBase. You can have any number of Publishing Projects, 

so your data can be published in many different ways. These describe:
•	 What selection of data you want to publish (e.g.: all the data; just the products on special 

offer; just the members based in New York, etc.)
•	 Which Publishing Stylesheet to use

•	 How you want the data sorted
•	 Which fields (parts of the data) you want to include
•	 Which Paragraph Stylesheet to apply to each paragraph
•	 Which pictures to include (optionally)
•	 Any rules to apply - for example, you could apply a rule that if a product is new, then in-

clude a special NEW! flag.
•	 Which format to save the published data in 
•	 What to name the published file and where to save it

The Paragraph Stylesheets are the key to managing the text formatting. 
To learn more about Publishing Projects, see this short video.
To learn more about Publishing Stylesheets, please see the Publishing Stylesheets Tutorial. 
For now though, let’s just jump in and see how easy it is to produce a beautifully formatted illus-

trated product catalogue.

https://www.catbase.com/publishing-projects-automate-the-publishing-process.html
https://www.catbase.com/publishing-style-sheets.html
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OK - Let’s see what it can do!

The Demo Database
Our Demo Database contains a few different Projects for various types of publishing project. 

The first Project that opens up when you start the database is a product catalogue for a fictitious 
bakery, The Sweet Tooth Fairy.

The bakery’s proprietor needs to produce several different publications from the database:
•	 An illustrated catalogue
•	 A simple price list
•	 A seasonal products catalogue

Although your own project probably is not a bakery goods catalogue, these examples will 
demonstrate how CatBase works and give you some ideas as to the possibilities it offers.

So let’s jump in and have a go ...

Publishing Examples

Example 1: An Illustrated Catalogue
1.	 Start CatBase in the usual way, as described in the Installation manual.
2.	 You should see a window similar to this:
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3.	 There are two data tables: Products and Variants. We’re looking at the Products table 
here. The Variants are options available for the Products - for example, a cake may be 
offered in 3 different sizes. This is what we call a relation: each Product can have any 
number of Variants related to it. (for more information about databases and relations, 
please see the Database 101 Tutorial).

4.	 Double-click on a Product name to open its record so that you can see what data we have 
for the Product. For example, if you open the Colourful Layers Cake record:

5.	 Note that there are three “tabs”, or pages, of info: Details, Categories, and Variants.
6.	 Click on the Variants tab:

7.	 This shows a list of the Variants that belong to that Product. 

NOTE: You have complete control over the setup of your tables, fields, and data entry 
windows. You can add/delete fields, place and size them on the window, and create as many 
Tabs to organise your data as you want.

8.	 Click the Save or Cancel button to close that window.

https://www.catbase.com/database-101.html
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9.	 Now, go to the Publishing main tab:

10.	 Expand the Publishing Projects topic on the left-hand side, and select the Publishing 
Project Catalog - Word:

For more info about Publishing Projects, see the Publishing Projects Tutorial.

11.	 Click the Publish Now button.
12.	 CatBase publishes the data, and saves it into a file called All categories.rtf in the Data 

Exports folder on your Desktop. You’ll see a message like this:

https://www.catbase.com/publishing-projects-automate-the-publishing-process.html
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13.	 Click the Show File Location button.
14.	 The Data Exports folder opens, with the published file selected.
15.	 Windows users: Double-click the file.
16.	 Mac users: Ctrl-click, or right-click, on the file and choose Open with ->Microsoft Word 

from the popup menu.
17.	 It should open up in Word, and should look similar to this:

Pretty cool, yes?



CatBase Demo Manual for Microsoft Word

Updated: March 2017	 6

Customising the document
Now that your data is in a Word document, you can make whatever changes you want to the 

style and formatting of the catalogue. Let’s look at a few examples.

Columns
This catalogue would probably look much better in two columns. It’s easy to change:
1.	 Select the Layout tab at the top of the window:

2.	 Click on the Columns icon and choose Two:

3.	 The document immediately looks better:
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The Options tables could be better styled: let’s add a bit of space above the column headings 
and add an underline.

1.	 Click anywhere within one of the table headers 

2.	 Go to the Format menu and choose Style ...
3.	 Notice that the table heading style is selected:
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4.	 Click the Modify ... button.



CatBase Demo Manual for Microsoft Word

Updated: March 2017	 9

5.	 Here you can change basic formatting options such as the font, style, size, colour etc. 
6.	 From the little popup at the bottom of the window which currently says Format, choose 

Paragraph:
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7.	 In the Spacing area, enter a small figure such as 3 into the Before field:

8.	 Click OK.
9.	 Now choose Border from the little popup at the bottom of the window:
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10.	 In the Preview area,click at the bottom of the image. A Line should appear there:

11.	 Click OK, OK again, then Apply.
12.	 Your tables should not look similar to this:

Much nicer!
Here’s something else that could be improved:
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I don’t like the way that the product details can get split across two columns or pages. All the 
info for one product should “stick together”. That’s easy to fix:

1.	 Click in the paragraph that contains one of the pictures, so that your cursor is right next to 
the picture.

2.	 Go to the Format menu and choose Style ...
3.	 The inline image style should be selected.
4.	 Click the Modify button.
5.	 Choose Paragraph from the little popup menu at the bottom of the window.
6.	 Go to the Line and Page Breaks tab and select the Keep with next check box:

7.	 Save it.
You can get creative and make your document look the way you want it to. You can add page 

headers and footers, change the styling of the text, and so on. 
This is great, but it could become somewhat tedious if you had to make these changes every 

time you published a catalogue.
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Using Templates
The solution is to use a template document. We’ve created one that you can try.
1.	 Launch Word, if it isn’t already running.
2.	 Choose Open ... from the File menu.
3.	 Locate the document Sweet Tooth Fairy Catalog.docx. You should find this in the Sample 

Documents folder within your CatBase Files folder.
4.	 Now you see the template named sweet tooth fairy catalog in the preview panel. It might 

be the only one there ... or you might see others,, depending on what’s on your computer.
5.	 Double-click on the sweet tooth fairy Catalog icon to open it.
6.	 The template opens. It has headers and footers set up.
7.	 Go to the Insert menu and choose File ...
8.	 Locate the file you published form CatBase. It’s called All_categories.rtf, and you will find it 

in the Data Exports folder on your Desktop.
9.	 Double click the All_categories.rtf file.
10.	 The file is imported into the Word template, and all the text is formatted. It should look 

something like this:



CatBase Demo Manual for Microsoft Word

Updated: March 2017	 14

How does it work?

Publishing Projects
So just how does Word know how to format the catalogue? It’s all controlled by the Publishing 

Projects in CatBase. Let’s take a look at the one we used to produce our example catalogue.
1.	 Go back to CatBase.
2.	 If it isn’t still displayed, select the Catalog -  Word Publishing Project (go to the main 

tab Publishing, expand the Publishing Projects topic on the left, then select Catalog - 
Word).

3.	 Double-click the Project Step “All Categories”. The Project Step window opens:

This window is organised into 5 sections:
1.	 Info about this Publishing Step: the Step name and description.
2.	 How is this Step managed?: Usually, you’ll choose Publishing Using a Set here. A 

Set is a pre-defined selection of records. (For more info about Sets, please see the Joy 
of Sets Tutorial). Sometimes, however, the selection of records can sometimes be more 
complex, and in that case we can write a script to manage them for you. Then you would 
select the Run a Script option instead. In our example, we’ve selected the Set called All 
categories.

3.	 Choose a Publishing Style and Publishing Destination: Here you select the Publishing 
Stylesheet to use when publishing this Project Step, and the Publishing Destination (this 
is the software that will be used to actually create the publication). In this example, RTF is 
selected, which is a format supported by Word.

https://www.catbase.com/the-joy-of-sets.html
https://www.catbase.com/the-joy-of-sets.html
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4.	 File Creation: By default, all files will be saved into a folder called Data Exports on your 
Desktop. This folder will be created if it doesn’t already exist. You can optionally select a 
different location for the files.

5.	 Optional Script Variable: Variables can be used within Publishing Stylesheets. For 
example, perhaps each time you publish your catalogue, you include prices in your own 
currency and also in another currency. CatBase can calculate the foreign currency values 
“on the fly”, but it needs to know what the current exchange rate is. You could enter the 
exchange rate as a Variable, and then CatBase can use that rate each time the catalogue 
is published.

Perhaps the most important part of the project is the Publishing Stylesheet. Let’s take a quick 
look at it.

Publishing Stylesheets
1.	 With the Publishing main tab still selected, expand the Publishing Stylesheets topic on 

the left of the window.
2.	 Select the Catalog for Word Publishing Stylesheet:

3.	 There are 5 Paragraphs. Double-click on the first Paragraph (product name). The 
Paragraph info window opens:
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4.	 There are a few options here. The important one is the Style Sheet:

Recall that in the Word document, the Stylesheet “product name” was selected for each product 
name in the catalogue:

This is how the Stylesheets are assigned to the various Paragraphs of data.
5.	 Click the Save or Cancel button to close the Paragraph window.
6.	 Click the little arrow next to the first Paragraph to expand it:
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There’s on Element in this Paragraph: the field, Product name.
7.	 Double-click the Product name Element:

There are 8 Element types:
•	 Bar Code
•	 Calculation
•	 Field
•	 Picture
•	 Punctuation
•	 Relation
•	 Rule
•	 Text

Each Paragraph can contain any number of Elements of various types. For detailed info about 
Elements, please see the Element Types Tutorial.

https://www.catbase.com/elements.html


CatBase Demo Manual for Microsoft Word

Updated: March 2017	 18

Example 2: A Simple Price List
In this example, we’re going to create a price list of all our Variants, sorted by SKU.
1.	 Go to Publishing->Publishing Projects->Price List by SKU.
2.	 Double-click on Step 1. It looks like this:

3.	 Make sure that RTF is selected as the Publishing Destination.
4.	 Click the Save button.
5.	 Click the Publish Now button.
6.	 When it’s done, click the Show File Location button on the alert window.
7.	 Open the rtf file in Word.
8.	 It should look similar to this:
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Notice that the prices are in bold, with a $ sign.
Suppose you want to use a different currency symbol (£ for example), and you want to put the 

prices in red if they are under 10.00. This is easy to manage with CatBase.
1.	 In CatBase, go to Publishing -> Publishing Stylesheets -> Price list by SKU
2.	 Expand the Prices paragraph:

3.	 Double-click the last Element (Price each).
4.	 The Element window opens, showing that the selected Element Type is Field and the 

selected Field is Price Each:
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5.	 Click the Element Type popup and select Rule, then click Yes. The window changes:

6.	 Click the Edit Rule button. The Rule window opens:
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We want to tell CatBase “If the price each is less than 10, then publish the Price Each and 
change the character style to “red price”, otherwise publish the Price Each without changing the 
Character Style.”

7.	 Click on the popup list of fields near the top of the window and choose Price Each:

8.	 Click on the popup next to the field list and choose “<” (“is less than”):
9.	 Enter “10” into the field next to the popups. It should now look like this:
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10.	 In the Then section, select the Publish the field radio button, and choose the Price each 
field from the popup list of fields next to it:

11.	 Towards the bottom of the window, choose Style for Element from the Style popup, and 
choose red price from the popup next to it:

12.	 Click on the Otherwise tab:

13.	 Select the Publish the Field radio button and the Price each field form the popup list:

The text at the top of the window should now display your complete rule:

14.	 Click the Save button to close the Rule window.
15.	 Go to the Preferences tab:
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16.	 Click the Number Format button in the Data Formatting section:
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17.	 In the Insert Text Before Number field, replace the $ sign with a different currency 
symbol.

18.	 Click OK.
19.	 Click Save to close that Element window.
20.	 Now republish the project. This time your document should look like this:

Example Three: Telephone Directories
In the Demo Database there are a number of Database Projects. We’ve been looking at the 

default Project (The Sweet Tooth Fairy) so far. Now let’s switch to another Database Project to see 
some different examples.

To switch Database Projects, go to the File menu and choose Switch Project. Select Tele-
phone Directory from the list that appears.

The screen changes. The Telephone Directory project has two data tables: White Pages and 
Yellow Pages:

We’ve set up a Publishing Project to publish both a White Pages and a Yellow Pages directory 
in one go.

1.	 Go to the Publishing tab.
2.	 Expand the Publishing Projects topic on the left of the window.
3.	 Select White and Yellow Pages - Word:
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4.	 There are two Project Steps in this Publishing Project - one to publish the Yellow Pages 
and one to publish the White Pages.

5.	 Click the Publish Now button. CatBase creates the two publications and alerts you when 
it’s done.

White Pages
1.	 Open the example Word document White_Pages.doc, which you’ll find in the Sample 

Documents folder in your CatBase Files folder..
2.	 Go to the Insert menu and choose File ....
3.	 Locate the White Pages file you just published (white_pages.rtf - you’ll find it in the Data 

Exports folder on your Desktop) and double-click it to open it.
4.	 Your document should look like this:
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 Let’s see the Yellow Pages ...

Yellow Pages
1.	 Open the example document Yellow Pages.doc, which you’ll find in the Sample 

documents folder.
2.	 Go to the Insert menu and choose File ...
3.	 Locate the file named Yellow_Pages.rtf, which you’ll find in the Data Exports folder on 

your Desktop, and double-click it.
4.	 Your document should look like this:
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Take a look at the Publishing Stylesheet, Yellow Pages for Word, to see how this publication 
has been set up in CatBase.

Example Four: Membership Directory
For this example we’re going to publish a Membership Directory such as you might wish to pro-

duce for your club or association.
First of all, switch to the Membership Directory project in CatBase:
1.	 Choose Switch Project from the File menu.
2.	 Double-click on Membership Directory.

Plain version without pictures
We’ll start with a simple directory.
1.	 Go to the Publishing main tab.
2.	 Expand the Publishing Projects topics on the left.
3.	 Select the Publishing Project Alpha Listings of all members - Word.
4.	 Click the Publish Now button.
5.	 When it’s done, open the resulting file (members.rtf) in Word. It should appear like this:
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6.	 You can easily jazz the design up a bit ... for example, change it to a four-column layout:

(See the notes earlier in this document for ideas about customising the Word document).

Membership Directory with Pictures
Would you like to include mug shots in your directory? Try this:
1.	 Go to Publishing->Publishing Projects
2.	 Select the Publishing Project Alpha Listings with mugshots - Word.
3.	 Click the Publish Now button.
4.	 Open the resulting file with Word.
5.	 Change the number of columns - for example, to 4.
6.	 It should look like this:
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As you can see, CatBase provides many ways to manage the publishing of your data!

What else can CatBase do?
Loads!
•	 Barcodes: Create all kinds of bar codes, including QR codes. See the Barcodes Tutorial.
•	 Emails: Send customised merged emails to contacts in your database. Learn more.
•	 Letters: Send customised merged letters to contacts in your database. 
•	 Labels: Create customised labels (mailing labels, product labels, name badges etc.). Learn 

more.
•	 Memos: Create Memos (reminders) and attach them to any record. Learn more.
•	 Import Data: You can import data from almost any source4, and you can use imported data 

to update existing data by matching up a key field such as a name, phone number, URN, etc. 
Learn more about importing data.

•	 Automated Backups: Set up a Backup schedule to make backups of your database at regu-
lar intervals, and maintain a log file of all modifications. Learn more.

•	 Sets: Create Sets of data to make it easy to find certain groups of data - for example, “all 
companies in New York” or “all lifetime members” or all members in New York who are life-
time members” or “all chocolate products”. Learn more!

•	 Quick Reports: Easily produce reports on your data. Learn more.
•	 Export data to other formats: You can export your data to various formats in addition to 

Word, including XML, HTML, Excel, csv, tab-delimited text, or another database such as 
MySql or SqlServer (Data Chameleon Edition). 

https://www.catbase.com/creating-barcodes.html
https://www.catbase.com/sending-and-receiving-emails.html
https://www.catbase.com/label-editor.html
https://www.catbase.com/label-editor.html
https://www.catbase.com/memos.html
https://www.catbase.com/importing-data-into-catbase.html
https://www.catbase.com/automated-backup-and-restore.html
https://www.catbase.com/the-joy-of-sets.html
https://www.catbase.com/quick-reports.html
https://www.catbase.com/catbase-data-chameleon.html
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•	 Event Scheduler: Set up scheduled events to automatically perform certain tasks at desig-
nated intervals - for example, import updated data from your SqlServer database every night. 
Learn more.

•	 Audit Trail: The Audit Trail Manager optionally keeps track of every change that is made to 
the database: who made the change, on what date at time, and exactly what was changed. 
Learn more.

•	 Custom Scripts and Modules: Do you need to do something special with your data? Per-
haps you have a complex pricing calculation that needs to be run whenever a record is 
saved, or you need to manage distributors and their selected products in a certain way. We 
can create custom scripts and modules to perform just about any task! For an example of a 
custom module, see this case study.

What next?
So, now you have an idea of what CatBase can do, and how it works with Word. If you would 

like to try it with your own project, we suggest following these steps:
1.	 If you need to learn about databases, see the Database 101 Tutorial.
2.	 If your project is similar to one of our example projects, why not start with that and amend 

it as needed to suit your needs?
3.	 To find out about setting up a new database project, see this step-by-step guide.
4.	 Learn about the CatBase User Interface.
5.	 Find out about importing data into your database.
6.	 Learn about Publishing Projects.
7.	 Got a question? Need help or advice setting up your project? Contact us! 
8.	 Ready to buy? Go to our online shop.

https://www.catbase.com/schedule-events-to-occur-according-to-a-designated-schedule.html
https://www.catbase.com/the-audit-trail-manager.html
https://www.catbase.com/analox-sensor-technology-case-study.html
https://www.catbase.com/database-101.html
https://www.catbase.com/a-step-by-step-guide-to-starting-a-new-database-publishing-project.html
https://www.catbase.com/the-catbase-user-interface.html
https://www.catbase.com/importing-data-into-catbase.html
https://www.catbase.com/publishing-projects-automate-the-publishing-process.html
https://www.catbase.com/contact-us.html
https://www.catbase.com/shop.html

